Platform Status - SmartTeach Assess

Incident Report for Teaching Strategies, LLC.

Resolved

This incident has been resolved and all child data is now up to date.
Posted Nov 25, 2025 - 12:23 EST

Identified

SmartTeach is experiencing delays in updates to child records. These changes may take longer to appear in other areas, including Assess, Finch, and Reports, but no data has been lost. We have identified the root cause and our team is working on a fix. We will continue to share updates as they become available.
Posted Nov 25, 2025 - 11:08 EST

Investigating

The Assess area of SmartTeach is experiencing issues and delays in data processing for a subset of customers. We are currently investigating the root cause of the issue and will provide more information as soon as possible.
Posted Nov 25, 2025 - 10:36 EST
This incident affected: SmartTeach (Assess Area, Report Area).