Platform Status - Tadpoles and Mobile Applications

Incident Report for Teaching Strategies, LLC.

Resolved

This incident has been resolved.
Posted Dec 02, 2025 - 09:40 EST

Identified

Users are currently unable to access our mobile applications—Tadpoles, SmartTeach, and Finch. We have identified the root cause and are working on a resolution.
Posted Dec 02, 2025 - 08:55 EST

Investigating

Users are unable to access Tadpoles and other our mobile applications. We are currently investigating the root cause of the issue and will provide more information as soon as possible.
Posted Dec 02, 2025 - 08:17 EST
This incident affected: Mobile Applications (SmartTeach Mobile, Finch Mobile) and Tadpoles.